jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dberning <davidbern...@hotmail.com>
Subject Verify Error - Do I need to rebuild Jackrabbit 1.3 for Java 1.4?
Date Fri, 13 Jul 2007 16:52:45 GMT

Hi,

I'm getting verify errors attempting to run JackRabbit 1.3 on WebSphere
5.1/RAD 6.0 (JDK 1.4). The errors only occur running in debug mode. 

I've read that JR 1.3 is compiled with Java 5, so I'm thinking that may be
my problem with the verify errors. Can't be sure though, so I'm trying to
rebuild Jackrabbit with Maven and the source. One thing I've noticed in
trying to do the rebuild from the 1.3 source is that some classes are not in
the source jar. Example: XPathTokenManager, which is where I'm getting the
verify error. 

I'm stuck as to where to go from here. Is it likely the verify errors are
due to the JackRabbit code I'm running? Any other ideas? I've also looked
into XML parser / classpath issues (which is another cause of that type of
error), but the only code I'm in in the error stack trace is JackRabbit
code. Should I rebuild JR to run under Java 1.4? If so, is there source code
missing from the source jar.

Thanks for your help,
Dave Berning   
-- 
View this message in context: http://www.nabble.com/Verify-Error---Do-I-need-to-rebuild-Jackrabbit-1.3-for-Java-1.4--tf4075651.html#a11583439
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message