jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frédéric Esnault <f...@legisway.com>
Subject RE: JCR-325 - multivalued properties
Date Mon, 11 Jun 2007 10:16:08 GMT
My bad, I retried this morning import/export, using system view export.
First I exported three nodes (contracts, contractors and contacts), then imported them back
(after deleting them of course), on the business root node, everything worked.
Then I tried to export the business root node (first "business" node under the repository
root) and re-import it into the repository (empty). Worked also.

The only difference is before I automatically imported under / (hardcoded). Now I added a
field in the form for the path to the node to import under. In the first case, I import my
three files under /lgw:root and in the second case, I import under /
It works. 

Frédéric Esnault - Ingénieur R&D

-----Message d'origine-----
De : Frédéric Esnault [mailto:fesn@legisway.com] 
Envoyé : lundi 11 juin 2007 11:34
À : users@jackrabbit.apache.org
Objet : JCR-325 - multivalued properties

I'd like to know if someone has more information about the problems I encountered trying to
export/import system view of my repository, using two different methods:


1. I created a "business root" called lgw:root, which is holding all my business content.
First method was to leave the node type informations in the repository and export the lgw:root
node (business export); like this I can use a fresh repository with just type informations
and import my lgw:root. But this doesn't work because of the previous error :

{http://www.jcp.org/jcr/mix/1.0}referenceable <http://www.jcp.org/jcr/mix/1.0%7dreferenceable>
: already contained in primary node



2. I exported everything (repository root), and import in a brand new fresh repository, nothing
at all in it. And it fails with another error :

/jcr:root/jcr:system/jcr:nodeTypes: cannot add a child to a protected node 


Is it a problem with jackrabbit or is it something I miss or do wrong?


Frederic Esnault


View raw message