jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frédéric Esnault <f...@legisway.com>
Subject RE: [JCR Controller] Out of memory - SOLVED
Date Fri, 08 Jun 2007 06:26:15 GMT
Congratulations ;)

It works, no out of memory error, and without the -Xmx512m, good work !

Two comments now :
1. As i told you, i work on a three node types test model : contracts -> contractors ->
contacts. What's strange is when I open a contract and double click on one contractor refence
in the table, it opens an select the corresponding node in the tree. But when I double click,
in the newly opened contractor, on a contact reference in the table, it selects the contact
property of the contractor node, it does not open the corresponding contact node. Any idea
why?
2. You should still have a look at the performance problem. Opening 3000 contracts node (just
selecting the contracts root and display the nodes) works but slowly. And the list of   "INFO
- resizeAll size=6"  displayed during the processing of the node opening makes me wonder why
it does this same operation so many times...

But well, the OOM problem is solved now, once again congratulations, and if you wish, I can
have a look at the performance problem when you release the source code.

Keep up the good work!

Oh and by the way, the import feature seems fine, with all options one could hope for. Nice
job there too. May be you could think of giving the choice between document view or system
view. I did it for my app and honestly the work to add the second option when the first one
is done is ...say....5 minutes work, for both import and export.

Frédéric Esnault - Ingénieur R&D
Legisway
60 boulevard de la mission Marchand
92400 Courbevoie La Défense
 
-----Message d'origine-----
De : Jacco van Weert [mailto:1111software@gmail.com] 
Envoyé : jeudi 7 juin 2007 20:58
À : users@jackrabbit.apache.org
Objet : Re: [JCR Controller] Out of memory

On 6/7/07, Frédéric Esnault <fesn@legisway.com> wrote:
>
> Sorry to bring bad news, but v0.63 doesn't solve the problem.



Well... I think (famous last words) I have now solved the problem.... I hope
so :-)...

Try the new v0.64 version


"fingers crossed"

Jacco




-- 
> -------------------------------------
> Jacco van Weert -- 1111software@gmail.com
> JCR Controller -- http://www.xs4all.nl/~weertj/jcr

Mime
View raw message