jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Estelle Carr" <estellec...@gmail.com>
Subject Re: Model 2 deployment on Weblogic
Date Tue, 05 Jun 2007 14:46:15 GMT
Shaun,
Thanks for your help with this. I eventually got it working, but had to make
lots of changes to the weblogic-ra.xml and ra.xml to get it working in
Weblogic 8.1.

Thanks again.


On 5/22/07, Shaun Barriball <sbarriba@yahoo.co.uk> wrote:
>
> Hi,
> I did the following:
> * download the Jackrabbit RAR file from
> http://jackrabbit.apache.org/downloads.cgi.
> * I followed the Weblogic RAR deploy instructions which included setting
> up
> a weblogic-ra.xml. An example one exists in
> "jackrabbit-jca\deploy\weblogic"
> within the Jackrabbit source code (attached).
> * I had to tweak the MANIFEST.MF as described below before deploying the
> RAR.
> * Make sure the JNDI name referenced in the ra.xml is as per your
> requirements.
> That should be it.
> Regards,
> S.
>
> -----Original Message-----
> From: Estelle Carr [mailto:estellecarr@gmail.com]
> Sent: 22 May 2007 16:32
> To: users@jackrabbit.apache.org
> Subject: Re: Model 2 deployment on Weblogic
>
> Hi Shaun,
> That sounds very interesting.  Do you know if there's any documentation on
> how to do this anywhere?
>
> Many thanks.
>
>
> On 5/22/07, Shaun Barriball <sbarriba@yahoo.co.uk> wrote:
> >
> > Hi Estelle,
> > I had a similar problem last week with Weblogic 9.1. Using the
> > Jackrabbit Resource Archive (RAR) package I was able to get it to work
> as
> follows:
> >
> > ==== Snippet from Post =======
> > I was able to successfully deploy Jackrabbit as a JCR Resource Archive
> > in Weblogic 9.1.
> >
> > RAR Modification Required for Weblogic 9.1
> > -------------------------------------------
> > Deploying the prebuilt Jackrabbit 1.3 RAR file within Weblogic 9.1
> > failed initially with:
> >
> > <19-May-2007 15:18:26 o'clock BST> <Error> <Console> <BEA-240003>
> > <Console encountered the following error
> > weblogic.application.library.LibraryDeploymentException:
> > [J2EE:160144]Failed
> > to register library Extension-Name: jackrabbit-jca,
> > Implementation-Version:
> > 1.3: Library cannot have Implementation-Version set, without also
> > specifying its Specification-Version.
> >
> > I was able to resolve this by removing the following line from
> > META-INF/Manifest.mf within the RAR file:
> > Implementation-Version: 1.3
> >
> > Hope this helps,
> > Shaun.
> >
> >
> >
> > -----Original Message-----
> > From: Estelle Carr [mailto:estellecarr@gmail.com]
> > Sent: 22 May 2007 16:10
> > To: users@jackrabbit.apache.org
> > Subject: Model 2 deployment on Weblogic
> >
> > Hi,
> > Has anyone successfully achieved model 2 deployment of a Jackrabbit
> > repository on Weblogic 8.1?  I'm having trouble declaring the
> > necessary JNDI resource, and am wondering if Weblogic actually
> > supports this?
> >
> > Thanks.
> >
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message