jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From martinfabbri <martinfab...@yahoo.com>
Subject Re: Startup errors model2 deployment
Date Mon, 11 Jun 2007 05:12:46 GMT



Herman Reintke wrote:
> 
> Herman Reintke <hreintke <at> tauri.nl> writes:
> 
>> I am trying to get a model2 deployment running on tomcat 5.5.23 
> 
>> Caused by: java.lang.NoClassDefFoundError:
>> org/apache/lucene/document/Field$Store
> 
>> Then I updated lucene from the 1.4.3 to the 2.1.0 version. But the result 
>>Caused by: java.lang.NoSuchMethodError:
>> org.apache.lucene.document.Document.add(Lorg/apache/lucene/document/Field;)V
>> 
>> Then I configured tomcat to use a "jcr-controller generated" repository. 
>>Failed to start database
>> 'c:/temp/version/db', see the next exc
> 
> 
> I found the reasons for the issues :
> 
> The first two are solved by using lucene 2.0.0 instead of 
>   lucene 1.4.3 or 2.1.0
> The third is solved by using Derby 10.2.2.0 instead of 10.1.3.1
> 
> Is somewhere a compatibility list for the versions of the dependent jars ?
> 
> Kind regards,
> 
> Herman Reintke
> 
> 
> 

Hi Herman:

    I’ve also run into the same issue that you described and actually
there’s a dependency list for Jackrabbit. Find that list at:
http://svn.apache.org/repos/asf/jackrabbit/site/dependency-convergence.html

    Cheers,

Martin Fabbri


-- 
View this message in context: http://www.nabble.com/Startup-errors-model2-deployment-tf3894485.html#a11055128
Sent from the Jackrabbit - Users mailing list archive at Nabble.com.


Mime
View raw message