jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Waschkowski" <mwaschkow...@gmail.com>
Subject config problem for model 2 and resolution
Date Mon, 07 May 2007 18:38:54 GMT
Hi,

I was setting up Jackrabbit for model 2 usage with tomcat and found that
Step 3 on this page:
   http://jackrabbit.apache.org/doc/deploy/howto-model2.html
didn't work for me. Specifically,

" In Tomcat versions 4.x and 5.0, add the following snippet in
server.xmlunder the
Context element of your web application. In Tomcat version 5.5, add the
snippet in your application's context.xml or
$CATALINA_HOME/conf/[enginename]/[hostname]/[webappname].xml. If you prefer
central configuration, you can add the configuration to the Host Context
section in the server.xml."

I tried to do central configuration (putting the resource link configuration
into server.xml) without success. As soon as I moved the resource link into:
C:\Java\tomcat-5.5.12\conf\context.xml

everything worked fine.

Therefore, I would recommend removing/amending the instructions to remove
the reference to server.xml, or at least mention usage of
$CATALINA_HOME/conf/context.xml.

Regards,

Mark Waschkowski

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message