jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Dullaart" <marcel.dulla...@gmail.com>
Subject Re: RMI connection
Date Fri, 20 Apr 2007 12:25:17 GMT
Hi,

Isn't there anyone at all that knows the answer? Or am I a complete
idiot that should have known this?
In that case please let me know, I am stuck with this.

Thanks again,
Marcel

On 4/20/07, Marcel Dullaart <marcel.dullaart@gmail.com> wrote:
> Hi all,
>
> I have setup a JBoss server instance and placed the
> jackrabbit-jca-1.2.3.rar and jackrabbit-jcr-rmi-1.2.3.jar in its
> deploy directory. From the, I removed the jcr-1.0.jar from
> jackrabbit-jca-1.2.3.rar and placed it in the server's lib diretory,
> also have I created a datasource connector (*-ds.xml) file and placed
> that in the deploy directory as well.
> JBoss start fine without errors.
>
> Then I tried to connect to it using the jcrClient (contrib), using
> jndi jcrServer, which succeeded.
> But I need an RMI connection so in the jcrClient I tried connect
> rmi://localhost:1099/jcrServer. This failed with the message:
> exception: java.rmi.ConnectIOException
> message: non-JRMP server at remote endpoint
>
> When using the jcrBrowser plugin from eclipse I get the same results.
>
> Can someone please explain to me what is wrong here?
>
>
> Thanks in advance,
> Marcel
>

Mime
View raw message