jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hatherly, Adam \(GE Money\)" <Adam.Hathe...@ge.com>
Subject Problems running Jackrabbit on Websphere 5.1
Date Thu, 12 Apr 2007 08:42:17 GMT
> Hi,
> 
> I am trying to deploy Jackrabbit onto Websphere in a shared (model 2) model. I have managed
to deploy the rar as a new resource adapter using the admin console, and configured the jndi
name and connection factory, etc. In my code I get a reference to the repository as follows:
> 
> String filePath = this.getClass().getClassLoader().getResource(SECURITYCONFIG).getFile();
> System.setProperty("java.security.auth.login.config",filePath);
> System.out.println("Login config now: " + System.getProperty("java.security.auth.login.config"));
> 
> InitialContext ctx = new InitialContext();
> _repository = (Repository) ctx.lookup("jcr/local");
> SimpleCredentials cred = new SimpleCredentials(JAAS_LOGIN,JAAS_PASSWORD.toCharArray());
> Session session = _repository.login(cred, null);
> 
> 
> My jaas config file contains:
> 
> Jackrabbit {
> org.apache.jackrabbit.core.security.SimpleLoginModule required 
> 		 anonymousId="anonymous";
> };
> 
> 
> But I am getting the below error when the repository.login method is called:
> 
> [11/04/07 14:02:41:023 BST] 7815db2a FreePool      E J2CA0046E: Method createManagedConnctionWithMCWrapper
caught an exception during creation of the ManagedConnection for resource jcr/local, throwing
ResourceAllocationException.  Original exception: javax.resource.ResourceException: Failed
to create session: No LoginModules configured for Jackrabbit: No LoginModules configured for
Jackrabbit
>         at org.apache.jackrabbit.jca.JCAManagedConnectionFactory.openSession(JCAManagedConnectionFactory.java:145)
>         at org.apache.jackrabbit.jca.JCAManagedConnectionFactory.createManagedConnection(JCAManagedConnectionFactory.java:165)
>         at org.apache.jackrabbit.jca.JCAManagedConnectionFactory.createManagedConnection(JCAManagedConnectionFactory.java:157)
>         at com.ibm.ejs.j2c.poolmanager.FreePool.createManagedConnectionWithMCWrapper(FreePool.java:1280)
>         at com.ibm.ejs.j2c.poolmanager.FreePool.createOrWaitForConnection(FreePool.java:1064)
>         at com.ibm.ejs.j2c.poolmanager.PoolManager.reserve(PoolManager.java:1571)
>         at com.ibm.ejs.j2c.ConnectionManager.allocateMCWrapper(ConnectionManager.java:622)
>         at com.ibm.ejs.j2c.ConnectionManager.allocateConnection(ConnectionManager.java:424)
>         at org.apache.jackrabbit.jca.JCARepositoryHandle.login(JCARepositoryHandle.java:98)
>         at org.apache.jackrabbit.jca.JCARepositoryHandle.login(JCARepositoryHandle.java:89)
>         at com.gecw.xfactor.contentrepository.JackRabbitSingleton.init(JackRabbitSingleton.java:115)
> 	...etc...
> 
> Any ideas what I am doing wrong?
> 
> Thanks,
> Adam.

Mime
View raw message