jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vit...@aim.com
Subject Re: Jackrabbit RMI server on AIX
Date Tue, 13 Feb 2007 22:37:20 GMT
 With latest JDK on AIX the following exception is thrown:
 I have tried compiling the RMI code on AIX with the same JDK version with no affect.
 This is really annoying. When I tried to compile the Jackrabbit code base (Rel. Ver. 1.2.1)
8 tests failed on AIX. But more about it separate thread. 
 
 What can be so special about Jackrabbit code to give following error? 
 
 AIX-JDK details for the braves :-)
 ============================
 > java -version
 java version "1.5.0"
 Java(TM) 2 Runtime Environment, Standard Edition (build pap32dev-20070201 (SR4))
 IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 AIX ppc-32 j9vmap3223-20070201 (JIT
 enabled)
 J9VM - 20070131_11312_bHdSMR
 JIT - 20070109_1805ifx1_r8
 GC - 200701_09)
 JCL - 20070126
 >
 
 Exception Trace:
 ===================
 java.lang.SecurityException: SHA MessageDigest not available
 at sun.rmi.server.Util.computeMethodHash(Util.java:378)
 at sun.rmi.server.UnicastServerRef$HashToMethod_Maps.createMap(UnicastSe
 rverRef.java:544)
 at sun.rmi.server.WeakClassHashMap.getMap(WeakClassHashMap.java:71)
 at sun.rmi.server.UnicastServerRef.exportObject(UnicastServerRef.java:19
 6)
 at java.rmi.server.UnicastRemoteObject.exportObject(UnicastRemoteObject.
 java:306)
 at java.rmi.server.UnicastRemoteObject.exportObject(UnicastRemoteObject.
 java:248)
 at java.rmi.server.UnicastRemoteObject.<init>(UnicastRemoteObject.java:1
 46)
 at java.rmi.server.UnicastRemoteObject.<init>(UnicastRemoteObject.java:1
 32)
 at org.apache.jackrabbit.rmi.server.ServerObject.<init>(ServerObject.jav
 a:70)
 at org.apache.jackrabbit.rmi.server.ServerRepository.<init>(ServerReposi
 tory.java:55)
 at org.apache.jackrabbit.rmi.server.ServerAdapterFactory.getRemoteReposi
 tory(ServerAdapterFactory.java:135)
    
 -----Original Message-----
 From: vitrpp@aim.com
 To: users@jackrabbit.apache.org
 Sent: Wed, 7 Feb 2007 8:05 PM
 Subject: Re: Jackrabbit RMI server on AIX
 
   Well, the simple RMI application works just fine.
 I will dig more into IBM JDK issues if any ...
 meanwhile any inputs are appreciated 
 thanks,
 Prasad
    
 -----Original Message-----
 From: jukka.zitting@gmail.com
 To: users@jackrabbit.apache.org
 Sent: Wed, 7 Feb 2007 12:11 AM
 Subject: Re: Jackrabbit RMI server on AIX
 
  Hi, 
 
 On 2/7/07, vitrpp@aim.com <vitrpp@aim.com> wrote: 
 > Has anyone executed Jackrabbit RMI server on AIX successfully ? 
 > serverAdapterFactry.getRemoteRepository() gives following exception stack ... 

 > Can someone confirm if this is IBM JDK (1.5) issue ? Looking at Jackrabbit 
 > code did not reveal any extra ordinary code. 
 
 Looks very much like a JVM issue, but without an AIX environment handy 
 I can't confirm this. You may want to check if the same problem 
 appears with a simple custom RMI server, like the one available in 
 Sun's RMI tutorial. 
 
 BR, 
 
 Jukka Zitting 
   
________________________________________________________________________
Check Out the new free AIM(R) Mail -- 2 GB of storage and industry-leading spam 
and email virus protection.
   
________________________________________________________________________
Check Out the new free AIM(R) Mail -- 2 GB of storage and industry-leading spam and email
virus protection.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message