jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: Unsupported language xpath in 1.2.1?
Date Wed, 07 Feb 2007 07:58:06 GMT
Hi,

On 2/7/07, Sridhar Raman <sridhar.raman@gmail.com> wrote:
> I am confused as to why I get a null string for the
> qm.getSupportedQueryLanguages() call.

Check that the jackrabbit-core jar file you have contains the
META-INF/services/org.apache.jackrabbit.core.query.QueryTreeBuilder
file. The Jackrabbit query engine uses the
javax.imageio.spi.ServiceRegistry mechanism to load the parsers for
the supported query languages. It seems like Jackrabbit is not finding
the default query parsers in your installation.

Do you use the official 1.2.1 binaries? Is there something special
with your class loading setup?

BR,

Jukka Zitting

Mime
View raw message