jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Douglass" <douglass.d...@gmail.com>
Subject Re: Jackrabbit on Jboss - security
Date Mon, 27 Nov 2006 21:00:30 GMT
Darren,

We've deployed Jackrabbit both in a Model 1 deployment and now Model 2 via
JCA on JBoss 4.0.4GA. Note that we're using JcrTemplate from the
Springmodules project, which is configured with the actual user/password
auth. credentials. Upon on initial deployment to a clean JBoss install we
received a JBoss error regarding a missing users.properties. I posted a
question to this list (search the archives, back about 2 months) but quickly
found the resolution was to create users.properties and roles.properties in
the conf directory.

For the Model 2 deployment via JCA almost nothing changed in our app except
the the JNDI lookup get the Repository and inject into the JcrTemplate. We
pretty much followed
http://wiki.apache.org/jackrabbit/JackrabbitOnJbossSecurity

Note that our DAO layer, again built with JcrTemplate, connects to JCR as a
single user that is unrelated to the actual application end-user. This keeps
things nice and simple, though this does require implementing ACLs in
application logic (via Spring AOP actually) instead of via
AccessManager/SimpleAccessManager.

Hope that helps,
Doug

On 11/27/06, Darren Hartford <dhartford@ghsinc.com> wrote:
>
> Added entry in the wiki -
> http://wiki.apache.org/jackrabbit/JackrabbitOnJbossSecurity
>
> Please update any incorrect information -- Authorization still needs to
> be worked on, or referenced if it is detailed elsewhere.
> -D
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message