jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ottinger, Joseph" <jottin...@techtarget.com>
Subject RE: unable to register jackrabbit as JCA in glassfish/Sun Appserver
Date Wed, 25 Oct 2006 10:56:25 GMT
Ruchi, have you opened the resource yet? 

-----Original Message-----
From: Ruchi.Goel@Sun.COM [mailto:Ruchi.Goel@Sun.COM] 
Sent: Wednesday, October 25, 2006 6:48 AM
To: users@jackrabbit.apache.org
Cc: Sandeep Soni
Subject: unable to register jackrabbit as JCA in glassfish/Sun Appserver

Hi ,
  I am trying to install Jackrabbit as JCA resource adapter in
Glassfish. I deployed *jackrabbit*-*jca*-1.0.rar  as connector module
and then following is the modified domain.xml  when appropriate changes
have been done via admin console.


*<connector-module directory-deployed="false" enabled="true" 
location="${com.sun.aas.instanceRoot}/applications/j2ee-modules/jackrabb
it-jca-1" 
name="jackrabbit-jca-1" object-type="user"/>
*
*<connector-resource enabled="true" jndi-name="jcr/globalRepository" 
object-type="user" pool-name="jackrabbit-connection-pool"/>
    <resource-adapter-config object-type="user" 
resource-adapter-name="jackrabbit-jca-1"/>

<connector-connection-pool
connection-definition-name="javax.jcr.Repository" 
fail-all-connections="false" idle-timeout-in-seconds="300" 
is-connection-validation-required="false" max-pool-size="32" 
max-wait-time-in-millis="60000" name="jackrabbit-connection-pool" 
pool-resize-quantity="2" resource-adapter-name="jackrabbit-jca-1" 
steady-pool-size="8">
      <property name="configFilePath" 
value="c:/testRepository/repository-xml.xml"/>
      <property name="repHomeDir" 
value="c:/testRepository/PortalRepository"/>
    </connector-connection-pool>
*

After server restart , I do not see any base directories under
*c:/testRepository/PortalRepository*


Any help appreciated. I have been told my alias memebers that this works
fine. Am I missing any step ?*


Thanks,
Ruchi


*

Mime
View raw message