jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Puchmann" <stefan.puchm...@hms.org>
Subject Problem after Adding a NodeType
Date Fri, 15 Sep 2006 12:28:38 GMT
Hello,

I have build up a few jsf pages for administrating nodetypes.
After successfully adding one nodetype i got an exception that the nodetype which was added
is not there:

at.join2learn.portlet.jackrabbit.core.exception.NoSuchNodeTypeException: No Such Node found:
test:showException
        at at.join2learn.portlet.jackrabbit.core.JackRabbitManagerImpl.getNodeType(JackRabbitManagerImpl.java:394)
        at at.join2learn.portlet.jackrabbit.core.JackRabbitManagerImpl.getAllNodeTypes(JackRabbitManagerImpl.java:318)
        at at.join2learn.portlet.nodetypemanager.managedBeans.NodeTypeManagerBean.getAllNodeTypes(NodeTypeManagerBean.java:129)
        at at.join2learn.portlet.nodetypemanager.managedBeans.NodeTypeManagerBean.getNodeTypes(NodeTypeManagerBean.java:155)
        at at.join2learn.portlet.nodetypemanager.managedBeans.NodeTypeManagerBean.getAllMixinTypes(NodeTypeManagerBean.java:171)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)

If have no idea why this happens but after restarting my webserver everything runs fine and
the node is also received.

Any ideas?

Regards,
Stefan



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message