jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Milan Trajkovic" <mil...@gmail.com>
Subject Re: JackRabbit - Tomcat two problems
Date Fri, 21 Jul 2006 08:43:43 GMT
I have already tried Tomcat 5.5.17, with same results (same
I have tried to replace Tomcat class in 5.5.15, and obtained same
exception. I did not managed to replace slf4j class, since I could not
find it in distribution jar.

Further, i have checkout Jackrabbit from repository, and tried to
replace all log calls in shutdown method with System.out.println();
and (compiled with 1.4.11 java, and tried to put it to Jackrabbit core
jar, but exception remains......

at org.apache.jackrabbit.core.RepositoryImpl.shutdown(RepositoryImpl.java:839)

Could you point me to the exact version of java file RepositryImpl,
that is used for 1.0.1 version of core. 839 line in version that I
have is not exactly log.info...statement,
but somewhere outside shutdown method. However, stacktrace shows that
exception is in shutdown, and debugger shows that log variable is
null. It is first statement where NPE could be thrown.


2006/7/20, Ceki Gulcu <ceki@qos.ch>:
> Hello Jukka,
> I think that Tomcat 5.5.17 contains the bug fix mentioned in issue #38579. If my
> memory serves me correctly, only TC 5.5.15 and 5.5.16 suffer from the
> afrementioned bug.
> Milan mentioned that he was using TomcaT 5.5.15. I suggest to upgrading to
> 5.5.17 before applying any patches.
> Hope this helps,

View raw message