jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Milan Trajkovic" <mil...@gmail.com>
Subject JackRabbit - Tomcat two problems
Date Wed, 12 Jul 2006 10:32:06 GMT
Hello.
I have Web application that should use jackrabbit repository.
Web server is Tomcat 5.5.15, Jackrabbit 1.0.1 distribution.

I am trying to make model 1 deployment to run.
1. I have followed instructions on site (copied necessary files, added
configuration to server.xml, and web.xml). However, as I have tried to
get (via JNDI) repository, I have got ConfigurationException:
Premature end of file exception. After several hours, I concluded that
message, even if it is thrown from configuration class, actually means
that there is no workspace.xml file in <REP_HOME>/workspace/default
i.e. there is file with that name, but with zero length. I have copied
file from my standalone repository (since configuration is basically
the same) and I have managed to start application. (In stand alone
test application,
that file was automatically created in the repository - so I have
expected that in webapp same will happen). Is there something that I
have done wrong?

2. As application is started, I have run few test methods (put, fetch
node etc.), and when I try to shut down Tomcat I get NPE, from
shutdown call

java.lang.NullPointerException at
org.apache.jackrabbit.core.RepositoryImpl.shutdown(RepositoryImpl.java:839)

I have attached source, and debugged code and it seems that logger is
null and it throws NPE.
I have also tried to add logger servlet from jackrabbit web
application, and to change my logger  configuration, but exception is
still there.
I would appreciate any help.

Regards,
Milan

Mime
View raw message