jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edgar Poce" <edgarp...@gmail.com>
Subject Re: Jackrabbit and Jboss (Shared Deployment Model)
Date Tue, 04 Jul 2006 16:45:45 GMT
hi,

On 7/4/06, Umesh Singh <umesh.singh@iogloballtd.com> wrote:
> Hi Edgar,
>
> Thanks for the wiki post. I am able to setup jackrabbit according to the
> instructions given there but still I am not able to do the RMI bit.
> Still I am not able to understand how putting just a jar in deploy
> folder will make it accessible over rmi?
>

there's a service descriptor inside the built jar that manages the
jcr-rmi lifecycle, it starts the jcr-rmi layer and binds it to a jndi
address.

> Should it not have some JBoss MBean deployed in SAR or Or I am missing
> something?
>

there's an MBean inside the jar. see
http://svn.apache.org/viewvc/jackrabbit/trunk/jcr-rmi/src/java/org/apache/jackrabbit/rmi/server/jmx/

br,
edgar

> Regards,
> Umesh
>
> Edgar Poce wrote:
> > Hi Umesh,
> >
> > On 7/3/06, Umesh Singh <umesh.singh@iogloballtd.com> wrote:
> >> Hi,
> >>
> >> I'm trying to deploy Jackrabbit under Jboss in a shared deployment model
> >>
> >
> > take a look to http://wiki.apache.org/jackrabbit/JackrabbitOnJBoss.
> > see the section "Deploy Jackrabbit with JCA".
> >
> > br,
> > edgar
> >
> >> I tried deploying directly using RegistryHelper which works and I can
> >> see on JBoss console that Repository has been deployed
> >> but when I try to do the lookup It seems Jackrabbit tries to start a
> >> new instance of the repository.  This fails because the .lock file
> >> exists from when I initially invoked RegistryHelper.
> >>
> >> Has anyone deployed under Jboss using model 2? Is there something wrong?
> >>
> >>
> >> Regards,
> >> Umesh
> >>
> >
>
>

Mime
View raw message