jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexandru Popescu" <the.mindstorm.mailingl...@gmail.com>
Subject Re: IndexOutOfBoundsException in QueryImpl.execute
Date Fri, 19 May 2006 06:22:13 GMT
On 5/19/06, Jukka Zitting <jukka.zitting@gmail.com> wrote:
> Hi,
>
> On 5/19/06, Alexandru Popescu <the.mindstorm.mailinglist@gmail.com> wrote:
> > Making the story shorter, after we removed this "custom" Lucene
> > version from the 3rd party jars, we have no longer see the problem
> > (now there are almost  18 hours from that point).
>
> Good to know that there was an explanation on the problem you were facing!
>
> I recall other Lucene version issues people have ran into, so I think
> I'll add an FAQ entry about this and we may want to consider adding
> some defensive coding in Jackrabbit that attempts to determine the
> Lucene version and warn about possible incompatibilities.
>
> BR,
>
> Jukka Zitting
>
> --
> Yukatan - http://yukatan.fi/ - info@yukatan.fi
> Software craftsmanship, JCR consulting, and Java development
>

This may be a good thing, but I am not sure it would have worked in
this particular case: the breaking version was a custom 1.4, so I
guess it would have been quite difficult to figure it out.

I really hope I haven't spoken too early :-).

./alex
--
.w( the_mindstorm )p.

Mime
View raw message