jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Reutegger <marcel.reuteg...@gmx.net>
Subject Re: Problem with indexes
Date Wed, 31 May 2006 20:28:39 GMT
Hi Petr,

There was a problem in the index merger which might be the cause of the 
query issue you discovered. I've created a jira issue:
http://issues.apache.org/jira/browse/JCR-448

It's already fixed in the jackrabbit trunk. If you want to test if the 
fix works for you, you have to check out the sources and compile them, 
or you can use this link to download a recent build that includes the 
mentioned change: http://service.gmx.net/mc/MVJEVor3l4uE6QCh7huUNpoLzc2xqv

Thanks again for your help

regards
  marcel

Petr Pytelka wrote:
> Hi Marcel,
> I've tried to find out more about my issue but didn't succeed.
> 
> There is small application which demonstrate the problem:
> http://217.11.254.42/download/index-problem.zip
> 
> Steps to reproduce:
> 
> Prerequisites:
> 1. This test is resource consuming - need computer with at least 512 MB, 
> better 1 GB
> 2. Package contain all needed libs and also source code (10kb) - I was 
> not able to create smaller example - sorry for that.
> 
> Test can be run using script "run-test" or "run-test.bat" - at the 
> beginning of each file is path to the Java.
> 
> Whole test is trying to create 10000 nodes
>  - Phase 1: Create 20 nodes
>  - Phase 2: Query for last created 20 nodes
> 
> Problem is that on faster machines this test fail around 3000-5000th 
> document - it is not possible to locate file. Query in repository is 
> based on the attribute values.
> 
> Maybe that the problem is in my code.. I'll really appreciate if you can 
> look on it...
> 
> Thanks, Petr


Mime
View raw message