jackrabbit-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Reutegger <marcel.reuteg...@gmx.net>
Subject Re: newbie question
Date Tue, 02 May 2006 15:43:54 GMT
dan z wrote:
> Just started looking at jackrabbit and have a question regarding the JDK 
> version requirement: the document says JDK1.4 is mandatory. But my web 
> app has to run on a WebSphere server that supports only J2ee1.3 and 
> won't be upgraded in short period.
> 
> Could anyone tell me what part of jackrabbit requires JDK1.4 and / or is 
> there any workaround?

there are various areas in jackrabbit that use 1.4 features:
- parsing of QName and Path uses regular expressions
- repository impl uses NIO
- javax.security is used for authentication
- javax.xml.transform for xml processing
- some collection classes that are only available in 1.4

I don't think there is a workaround to get jackrabbit working with 1.3. 
some of the missing features might be available as separate jar files 
from sun, but getting the NIO feature into a 1.3 jdk seems hopeless.

regards
  marcel




Mime
View raw message