jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Reutegger (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (OAK-7589) [DirectBinaryAccess][DISCUSS] Client facing API
Date Tue, 17 Jul 2018 06:28:00 GMT

    [ https://issues.apache.org/jira/browse/OAK-7589?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16545538#comment-16545538
] 

Marcel Reutegger edited comment on OAK-7589 at 7/17/18 6:27 AM:
----------------------------------------------------------------

I made a few more changes on top of your PR. See my [OAK-7589 branch|https://github.com/mreutegg/jackrabbit/tree/OAK-7589],
though the github website is currently down for me. I also left a few TODOs. What do you think
about those?

I was also wondering if {{BinaryDirectDownload}} and {{BinaryDirectUpload}} should be renamed
to simply {{BinaryDownload}} and {{BinaryUpload}}. This would better match {{JackrabbitValueFactory.initiateBinaryUpload()}}.
Furthermore, simplify {{getDownloadURI()}} to {{getURI()}}? The term download is already present
in the name of the interface.


was (Author: mreutegg):
I made a few more changes on top of your PR. See my [OAK-7589 branch|https://github.com/mreutegg/jackrabbit-oak/tree/OAK-7589],
though the github website is currently down for me. I also left a few TODOs. What do you think
about those?

I was also wondering if {{BinaryDirectDownload}} and {{BinaryDirectUpload}} should be renamed
to simply {{BinaryDownload}} and {{BinaryUpload}}. This would better match {{JackrabbitValueFactory.initiateBinaryUpload()}}.
Furthermore, simplify {{getDownloadURI()}} to {{getURI()}}? The term download is already present
in the name of the interface.

> [DirectBinaryAccess][DISCUSS] Client facing API
> -----------------------------------------------
>
>                 Key: OAK-7589
>                 URL: https://issues.apache.org/jira/browse/OAK-7589
>             Project: Jackrabbit Oak
>          Issue Type: Technical task
>            Reporter: Matt Ryan
>            Assignee: Matt Ryan
>            Priority: Major
>
> From a discussion w/ [~mreutegg]:  Suggested that we move the API changes out of oak-jcr
(i.e. org.apache.jackrabbit.oak.jcr.api.binary.HttpBinaryProvider and org.apache.jackrabbit.oak.jcr.api.binary.HttpBinaryDownload
to a different package to avoid unnecessary API changes to oak-jcr.
> This issue should also be used to discuss how exactly the client facing API is designed.




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message