jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Reschke (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OAK-7414) oak-it-osgi fails on Java 10
Date Fri, 27 Jul 2018 08:43:00 GMT

     [ https://issues.apache.org/jira/browse/OAK-7414?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Julian Reschke updated OAK-7414:
--------------------------------
    Fix Version/s: 1.8.6

> oak-it-osgi fails on Java 10
> ----------------------------
>
>                 Key: OAK-7414
>                 URL: https://issues.apache.org/jira/browse/OAK-7414
>             Project: Jackrabbit Oak
>          Issue Type: Bug
>          Components: it
>            Reporter: Julian Reschke
>            Assignee: Julian Reschke
>            Priority: Major
>              Labels: candidate_oak_1_6
>             Fix For: 1.10, 1.9.1, 1.8.6
>
>         Attachments: OAK-7414.diff
>
>
> {noformat}
> ERROR: Bundle org.ops4j.pax.exam [1] Error starting link:classpath:META-INF/links/org.ops4j.pax.exam.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam [1](R 1.0): missing requirement [org.ops4j.pax.exam [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)] Unresolved requirements: [[org.ops4j.pax.exam [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam [1](R 1.0): missing requirement [org.ops4j.pax.exam [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)] Unresolved requirements: [[org.ops4j.pax.exam [1](R 1.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.exam.inject [2] Error starting link:classpath:META-INF/links/org.ops4j.pax.exam.inject.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam.inject [2](R 2.0): missing requirement [org.ops4j.pax.exam.inject [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.exam.inject [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam.inject [2](R 2.0): missing requirement [org.ops4j.pax.exam.inject [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.exam.inject [2](R 2.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.exam.extender.service [3] Error starting link:classpath:META-INF/links/org.ops4j.pax.extender.service.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam.extender.service [3](R 3.0): missing requirement [org.ops4j.pax.exam.extender.service [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.exam.extender.service [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam.extender.service [3](R 3.0): missing requirement [org.ops4j.pax.exam.extender.service [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.exam.extender.service [3](R 3.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.base [5] Error starting link:classpath:META-INF/links/org.ops4j.base.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl) Unresolved requirements: [[org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl) Unresolved requirements: [[org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.swissbox.core [6] Error starting link:classpath:META-INF/links/org.ops4j.pax.swissbox.core.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.core [6](R 6.0): missing requirement [org.ops4j.pax.swissbox.core [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)] Unresolved requirements: [[org.ops4j.pax.swissbox.core [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.core [6](R 6.0): missing requirement [org.ops4j.pax.swissbox.core [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)] Unresolved requirements: [[org.ops4j.pax.swissbox.core [6](R 6.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.swissbox.extender [7] Error starting link:classpath:META-INF/links/org.ops4j.pax.swissbox.extender.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.extender [7](R 7.0): missing requirement [org.ops4j.pax.swissbox.extender [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.swissbox.extender [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.extender [7](R 7.0): missing requirement [org.ops4j.pax.swissbox.extender [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.swissbox.extender [7](R 7.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.swissbox.framework [8] Error starting link:classpath:META-INF/links/org.ops4j.pax.swissbox.framework.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.framework [8](R 8.0): missing requirement [org.ops4j.pax.swissbox.framework [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.spi)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)] Unresolved requirements: [[org.ops4j.pax.swissbox.framework [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.spi)(version>=1.4.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.framework [8](R 8.0): missing requirement [org.ops4j.pax.swissbox.framework [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.spi)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)] Unresolved requirements: [[org.ops4j.pax.swissbox.framework [8](R 8.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.spi)(version>=1.4.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.swissbox.tracker [10] Error starting link:classpath:META-INF/links/org.ops4j.pax.swissbox.tracker.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.tracker [10](R 10.0): missing requirement [org.ops4j.pax.swissbox.tracker [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.swissbox.tracker [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.swissbox.tracker [10](R 10.0): missing requirement [org.ops4j.pax.swissbox.tracker [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] Unresolved requirements: [[org.ops4j.pax.swissbox.tracker [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.exam.invoker.junit [14] Error starting link:classpath:META-INF/links/org.ops4j.pax.exam.invoker.junit.link (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam.invoker.junit [14](R 14.0): missing requirement [org.ops4j.pax.exam.invoker.junit [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.tracker)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.swissbox.tracker [10](R 10.0): missing requirement [org.ops4j.pax.swissbox.tracker [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]] Unresolved requirements: [[org.ops4j.pax.exam.invoker.junit [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.tracker)(version>=1.7.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.exam.invoker.junit [14](R 14.0): missing requirement [org.ops4j.pax.exam.invoker.junit [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.tracker)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.pax.swissbox.tracker [10](R 10.0): missing requirement [org.ops4j.pax.swissbox.tracker [10](R 10.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.lang)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve org.ops4j.base [5](R 5.0): missing requirement [org.ops4j.base [5](R 5.0)] osgi.wiring.package; (osgi.wiring.package=javax.net.ssl)]] Unresolved requirements: [[org.ops4j.pax.exam.invoker.junit [14](R 14.0)] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.tracker)(version>=1.7.0)(!(version>=2.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.felix.scr [15] Error starting mvn:org.apache.felix/org.apache.felix.scr/2.0.12 (org.osgi.framework.BundleException: Unable to resolve org.apache.felix.scr [15](R 15.0): missing requirement [org.apache.felix.scr [15](R 15.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE/compact1)(version=1.8))) Unresolved requirements: [[org.apache.felix.scr [15](R 15.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE/compact1)(version=1.8)))])
> org.osgi.framework.BundleException: Unable to resolve org.apache.felix.scr [15](R 15.0): missing requirement [org.apache.felix.scr [15](R 15.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE/compact1)(version=1.8))) Unresolved requirements: [[org.apache.felix.scr [15](R 15.0)] osgi.ee; (|(&(osgi.ee=JavaSE)(version=1.6))(&(osgi.ee=JavaSE/compact1)(version=1.8)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.osgi.dto [16] Error starting mvn:org.osgi/org.osgi.dto/1.0.0 (org.osgi.framework.BundleException: Unable to resolve org.osgi.dto [16](R 16.0): missing requirement [org.osgi.dto [16](R 16.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5)) Unresolved requirements: [[org.osgi.dto [16](R 16.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5))])
> org.osgi.framework.BundleException: Unable to resolve org.osgi.dto [16](R 16.0): missing requirement [org.osgi.dto [16](R 16.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5)) Unresolved requirements: [[org.osgi.dto [16](R 16.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.5))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.ops4j.pax.logging.pax-logging-api [19] Error starting mvn:org.ops4j.pax.logging/pax-logging-api/1.7.2 (org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) Unresolved requirements: [[org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)])
> org.osgi.framework.BundleException: Unable to resolve org.ops4j.pax.logging.pax-logging-api [19](R 19.0): missing requirement [org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) Unresolved requirements: [[org.ops4j.pax.logging.pax-logging-api [19](R 19.0)] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.commons.io [21] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/commons-io.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.commons.io [21](R 21.0): missing requirement [org.apache.commons.io [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[org.apache.commons.io [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))])
> org.osgi.framework.BundleException: Unable to resolve org.apache.commons.io [21](R 21.0): missing requirement [org.apache.commons.io [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6)) Unresolved requirements: [[org.apache.commons.io [21](R 21.0)] osgi.ee; (&(osgi.ee=JavaSE)(version=1.6))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.jackrabbit-api [23] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/jackrabbit-api.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.jackrabbit-api [23](R 23.0): missing requirement [org.apache.jackrabbit.jackrabbit-api [23](R 23.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.jackrabbit-api [23](R 23.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.jackrabbit-api [23](R 23.0): missing requirement [org.apache.jackrabbit.jackrabbit-api [23](R 23.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.jackrabbit-api [23](R 23.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.jackrabbit-data [24] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/jackrabbit-data.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.jackrabbit-data [24](R 24.0): missing requirement [org.apache.jackrabbit.jackrabbit-data [24](R 24.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.apache.jackrabbit.jackrabbit-data [24](R 24.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.jackrabbit-data [24](R 24.0): missing requirement [org.apache.jackrabbit.jackrabbit-data [24](R 24.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.apache.jackrabbit.jackrabbit-data [24](R 24.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.jackrabbit-jcr-commons [25] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/jackrabbit-jcr-commons.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.jackrabbit-jcr-commons [25](R 25.0): missing requirement [org.apache.jackrabbit.jackrabbit-jcr-commons [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr.lock)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve javax.jcr [26](R 26.0): missing requirement [javax.jcr [26](R 26.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax)] Unresolved requirements: [[org.apache.jackrabbit.jackrabbit-jcr-commons [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr.lock)(version>=2.0.0)(!(version>=3.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.jackrabbit-jcr-commons [25](R 25.0): missing requirement [org.apache.jackrabbit.jackrabbit-jcr-commons [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr.lock)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve javax.jcr [26](R 26.0): missing requirement [javax.jcr [26](R 26.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax)] Unresolved requirements: [[org.apache.jackrabbit.jackrabbit-jcr-commons [25](R 25.0)] osgi.wiring.package; (&(osgi.wiring.package=javax.jcr.lock)(version>=2.0.0)(!(version>=3.0.0)))]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle javax.jcr [26] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/jcr.jar (org.osgi.framework.BundleException: Unable to resolve javax.jcr [26](R 26.0): missing requirement [javax.jcr [26](R 26.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) Unresolved requirements: [[javax.jcr [26](R 26.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax)])
> org.osgi.framework.BundleException: Unable to resolve javax.jcr [26](R 26.0): missing requirement [javax.jcr [26](R 26.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax) Unresolved requirements: [[javax.jcr [26](R 26.0)] osgi.wiring.package; (osgi.wiring.package=org.xml.sax)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle io.dropwizard.metrics.core [27] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/metrics-core.jar (org.osgi.framework.BundleException: Unable to resolve io.dropwizard.metrics.core [27](R 27.0): missing requirement [io.dropwizard.metrics.core [27](R 27.0)] osgi.wiring.package; (osgi.wiring.package=javax.management) Unresolved requirements: [[io.dropwizard.metrics.core [27](R 27.0)] osgi.wiring.package; (osgi.wiring.package=javax.management)])
> org.osgi.framework.BundleException: Unable to resolve io.dropwizard.metrics.core [27](R 27.0): missing requirement [io.dropwizard.metrics.core [27](R 27.0)] osgi.wiring.package; (osgi.wiring.package=javax.management) Unresolved requirements: [[io.dropwizard.metrics.core [27](R 27.0)] osgi.wiring.package; (osgi.wiring.package=javax.management)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-api [28] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-api.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-api [28](R 28.0): missing requirement [org.apache.jackrabbit.oak-api [28](R 28.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-api [28](R 28.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-api [28](R 28.0): missing requirement [org.apache.jackrabbit.oak-api [28](R 28.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-api [28](R 28.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-blob-plugins [29] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-blob-plugins.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-blob-plugins [29](R 29.0): missing requirement [org.apache.jackrabbit.oak-blob-plugins [29](R 29.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-blob-plugins [29](R 29.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-blob-plugins [29](R 29.0): missing requirement [org.apache.jackrabbit.oak-blob-plugins [29](R 29.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-blob-plugins [29](R 29.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-blob [30] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-blob.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-blob [30](R 30.0): missing requirement [org.apache.jackrabbit.oak-blob [30](R 30.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-blob [30](R 30.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-blob [30](R 30.0): missing requirement [org.apache.jackrabbit.oak-blob [30](R 30.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-blob [30](R 30.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-commons [31] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-commons.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-commons [31](R 31.0): missing requirement [org.apache.jackrabbit.oak-commons [31](R 31.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-commons [31](R 31.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-commons [31](R 31.0): missing requirement [org.apache.jackrabbit.oak-commons [31](R 31.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-commons [31](R 31.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-core-spi [32] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-core-spi.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-core-spi [32](R 32.0): missing requirement [org.apache.jackrabbit.oak-core-spi [32](R 32.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-core-spi [32](R 32.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-core-spi [32](R 32.0): missing requirement [org.apache.jackrabbit.oak-core-spi [32](R 32.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-core-spi [32](R 32.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-core [33] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-core.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-core [33](R 33.0): missing requirement [org.apache.jackrabbit.oak-core [33](R 33.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-core [33](R 33.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-core [33](R 33.0): missing requirement [org.apache.jackrabbit.oak-core [33](R 33.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-core [33](R 33.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-jcr [34] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-jcr.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-jcr [34](R 34.0): missing requirement [org.apache.jackrabbit.oak-jcr [34](R 34.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-jcr [34](R 34.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-jcr [34](R 34.0): missing requirement [org.apache.jackrabbit.oak-jcr [34](R 34.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-jcr [34](R 34.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-lucene [35] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-lucene.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-lucene [35](R 35.0): missing requirement [org.apache.jackrabbit.oak-lucene [35](R 35.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-lucene [35](R 35.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-lucene [35](R 35.0): missing requirement [org.apache.jackrabbit.oak-lucene [35](R 35.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-lucene [35](R 35.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-query-spi [36] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-query-spi.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-query-spi [36](R 36.0): missing requirement [org.apache.jackrabbit.oak-query-spi [36](R 36.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-query-spi [36](R 36.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-query-spi [36](R 36.0): missing requirement [org.apache.jackrabbit.oak-query-spi [36](R 36.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-query-spi [36](R 36.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-security-spi [37] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-security-spi.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-security-spi [37](R 37.0): missing requirement [org.apache.jackrabbit.oak-security-spi [37](R 37.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-security-spi [37](R 37.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-security-spi [37](R 37.0): missing requirement [org.apache.jackrabbit.oak-security-spi [37](R 37.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-security-spi [37](R 37.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-segment-tar [38] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-segment-tar.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-segment-tar [38](R 38.0): missing requirement [org.apache.jackrabbit.oak-segment-tar [38](R 38.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-segment-tar [38](R 38.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-segment-tar [38](R 38.0): missing requirement [org.apache.jackrabbit.oak-segment-tar [38](R 38.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-segment-tar [38](R 38.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-store-composite [39] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-store-composite.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-store-composite [39](R 39.0): missing requirement [org.apache.jackrabbit.oak-store-composite [39](R 39.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-store-composite [39](R 39.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-store-composite [39](R 39.0): missing requirement [org.apache.jackrabbit.oak-store-composite [39](R 39.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-store-composite [39](R 39.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-store-document [40] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-store-document.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-store-document [40](R 40.0): missing requirement [org.apache.jackrabbit.oak-store-document [40](R 40.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-store-document [40](R 40.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-store-document [40](R 40.0): missing requirement [org.apache.jackrabbit.oak-store-document [40](R 40.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-store-document [40](R 40.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.jackrabbit.oak-store-spi [41] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/oak-store-spi.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-store-spi [41](R 41.0): missing requirement [org.apache.jackrabbit.oak-store-spi [41](R 41.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-store-spi [41](R 41.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-store-spi [41](R 41.0): missing requirement [org.apache.jackrabbit.oak-store-spi [41](R 41.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation) Unresolved requirements: [[org.apache.jackrabbit.oak-store-spi [41](R 41.0)] osgi.wiring.package; (osgi.wiring.package=javax.annotation)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> ERROR: Bundle org.apache.tika.core [42] Error starting file:/C:/projects/apache/oak/trunk/oak-it-osgi/target/test-bundles/tika-core.jar (org.osgi.framework.BundleException: Unable to resolve org.apache.tika.core [42](R 42.0): missing requirement [org.apache.tika.core [42](R 42.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.apache.tika.core [42](R 42.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)])
> org.osgi.framework.BundleException: Unable to resolve org.apache.tika.core [42](R 42.0): missing requirement [org.apache.tika.core [42](R 42.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto) Unresolved requirements: [[org.apache.tika.core [42](R 42.0)] osgi.wiring.package; (osgi.wiring.package=javax.crypto)]
>         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4148)
>         at org.apache.felix.framework.Felix.startBundle(Felix.java:2118)
>         at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1372)
>         at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
>         at java.base/java.lang.Thread.run(Thread.java:844)
> [ERROR] Tests run: 5, Failures: 0, Errors: 5, Skipped: 0, Time elapsed: 57.199 s <<< FAILURE! - in org.apache.jackrabbit.oak.osgi.OSGiIT
> [ERROR] listServices(org.apache.jackrabbit.oak.osgi.OSGiIT)  Time elapsed: 10.007 s  <<< ERROR!
> org.ops4j.pax.swissbox.tracker.ServiceLookupException: gave up waiting for service org.ops4j.pax.exam.ProbeInvoker
> [ERROR] listBundles(org.apache.jackrabbit.oak.osgi.OSGiIT)  Time elapsed: 9.999 s  <<< ERROR!
> org.ops4j.pax.swissbox.tracker.ServiceLookupException: gave up waiting for service org.ops4j.pax.exam.ProbeInvoker
> [ERROR] bundleStates(org.apache.jackrabbit.oak.osgi.OSGiIT)  Time elapsed: 10.002 s  <<< ERROR!
> org.ops4j.pax.swissbox.tracker.ServiceLookupException: gave up waiting for service org.ops4j.pax.exam.ProbeInvoker
> [ERROR] testNodeStore(org.apache.jackrabbit.oak.osgi.OSGiIT)  Time elapsed: 10.008 s  <<< ERROR!
> org.ops4j.pax.swissbox.tracker.ServiceLookupException: gave up waiting for service org.ops4j.pax.exam.ProbeInvoker
> [ERROR] testRepository(org.apache.jackrabbit.oak.osgi.OSGiIT)  Time elapsed: 10 s  <<< ERROR!
> org.ops4j.pax.swissbox.tracker.ServiceLookupException: gave up waiting for service org.ops4j.pax.exam.ProbeInvoker
> [INFO]
> [INFO] Results:
> [INFO]
> [ERROR] Errors:
> [ERROR]   OSGiIT.bundleStates ▒ ServiceLookup gave up waiting for service org.ops4j.pax....
> [ERROR]   OSGiIT.listBundles ▒ ServiceLookup gave up waiting for service org.ops4j.pax.e...
> [ERROR]   OSGiIT.listServices ▒ ServiceLookup gave up waiting for service org.ops4j.pax....
> [ERROR]   OSGiIT.testNodeStore ▒ ServiceLookup gave up waiting for service org.ops4j.pax...
> [ERROR]   OSGiIT.testRepository ▒ ServiceLookup gave up waiting for service org.ops4j.pa...
> [INFO]
> [ERROR] Tests run: 5, Failures: 0, Errors: 5, Skipped: 0
> {noformat}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message