jackrabbit-oak-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Reschke <julian.resc...@gmx.de>
Subject Re: remaining test failures
Date Tue, 14 Jan 2014 17:35:10 GMT
On 2014-01-14 12:13, Julian Reschke wrote:
> On 2014-01-14 11:21, Michael Dürig wrote:
>>
>>
>> On 10.1.14 2:53 , Julian Reschke wrote:
>>> On my slower machines, the tests usually pass. On my 64 bit i7 desktop,
>>> I occasionally have test failures:
>>>
>>> A) Observation
>>>
>>> testSingleMixin(org.apache.jackrabbit.core.observation.MixinTest): Path
>>> /testroot/node1/prop1 not found in events.
>>>
>>> testMultipleMixinOnNode(org.apache.jackrabbit.core.observation.MixinTest):
>>>
>>>
>>> Path /testroot/node1/prop1 not found in events.
>>
>> I can't reproduce those. Looking at the code I can make a few guesses:
>>
>> - There might be a race in the test cases: in the presence of "spurious"
>> events preceding the expected events:
>> org.apache.jackrabbit.test.api.observation.EventResult#getEvents(long)
>> will return the spurious events instead of waiting for the expected
>> events in this case.
>>
>> - If this only happens with the SegmentMK it might be causes by an issue
>> I stumbled on last week. See
>> http://markmail.org/message/gk55nt5rg7owxuw6.
>
> FWIW, Manfred tried yesterday and saw the same problems on his Windows
> machine (quad core), but not on his ancient MacBook.

FWIW, right now I can't seem to reproduce them as well.

Best regards, Julian


Mime
View raw message