jackrabbit-oak-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Mueller (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-75) specify format and semantics of 'filter' parameter in MicroKernel API
Date Thu, 03 May 2012 15:06:50 GMT

    [ https://issues.apache.org/jira/browse/OAK-75?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13267487#comment-13267487

Thomas Mueller commented on OAK-75:

> my intention was to specify the 'path' filter on getJournal() and diff() only.

Yes, makes sense.

> since getRevisionHistory doesn't return tree data i didn't add a filter parameter.

For a virtual repository implementation, I think it would make sense to filter the revision
history by path as well. Otherwise the virtual repository implementation would have to read
from all bound repositories each time the method is called, and not just those repositories
that match the filter. It somewhat limits scalability if there is no filter.

> i wanted to keep the proposal simple

Simple is good :-)

> i am afraid that it will add considerable complexity to the API semantics

Would that also be the case if we only add the (path-) filter at getRevisionHistory, and keep
waitForCommit and getHeadRevision as they are now?

> specify format and semantics of 'filter' parameter in MicroKernel API
> ---------------------------------------------------------------------
>                 Key: OAK-75
>                 URL: https://issues.apache.org/jira/browse/OAK-75
>             Project: Jackrabbit Oak
>          Issue Type: New Feature
>          Components: mk
>            Reporter: Stefan Guggisberg
> the following MicroKernel methods contain a 'filter' string parameter:
> - getJournal
> - diff
> - getNodes
> through the filter an API client could e.g. specify:
> - special 'meta' properties to be included (e.g. ":hash")
> - glob patterns on the names of properties/child nodes to be included/excluded
> - path filter (for getJournal and diff)
> format/detailed semantics TBD, here's an initial proposal (json):
> {code} 
> {
>   "path" : "/some/path",
>   "incl" : [ ":hash", "*" ],
>   "excl" : [ "tmp*" ]
> }
> {code} 
> name filter patterns should ideally be the same 
> format as specified for JCR Node.getNodes/getProperties.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message