jackrabbit-oak-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] [Resolved] (OAK-65) Naming of NodeState and related classes
Date Thu, 03 May 2012 22:20:48 GMT

     [ https://issues.apache.org/jira/browse/OAK-65?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Dürig resolved OAK-65.
------------------------------

       Resolution: Fixed
    Fix Version/s: 0.3

Resolving as fixed. The API restructuring (ContentSession et. all) took care of this.
                
> Naming of NodeState and related classes
> ---------------------------------------
>
>                 Key: OAK-65
>                 URL: https://issues.apache.org/jira/browse/OAK-65
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: core, mk
>            Reporter: Michael Dürig
>             Fix For: 0.3
>
>
> As discussed here [1] we should rethink the nameing of the NodeState and related classes.

> I suggest the following renaming:
> NodeState -> NodeData
> PropertyState -> PropertyData
> TransientNodeState -> NodeState
> KernelNodeState -> KernelNodeData
> My reasoning: the current NodeState and PropertyState classes are immutable (and thus
> represent pure values i.e. data). The word state implies mutability
> (after all OOP is about mutation of state all over) so renaming
> TransientNodeState to NodeState should make sense. Also the oak API will
> be more publicly visible than the lower level MK API. So having catchy
> names there is a plus. 
> http://markmail.org/thread/xi5dgjljduc7y7eq

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message