jackrabbit-oak-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Guggisberg (JIRA)" <j...@apache.org>
Subject [jira] [Created] (OAK-116) MicroKernel API: clarify semantics of getNodes depth, offset and count parameters
Date Thu, 24 May 2012 14:36:56 GMT
Stefan Guggisberg created OAK-116:
-------------------------------------

             Summary: MicroKernel API: clarify semantics of getNodes depth, offset and count
parameters
                 Key: OAK-116
                 URL: https://issues.apache.org/jira/browse/OAK-116
             Project: Jackrabbit Oak
          Issue Type: Improvement
          Components: mk
            Reporter: Stefan Guggisberg
             Fix For: 0.3


{{MicroKernel.getNode(String path, String revisionId, int depth, long offset, int count, String
filter)}}

the semantics of {{depth}} as currently documented in the javadoc is inconsistent: 
- depth=0 returns empty child node objects
- depth=1 OTOH doesn't return empty grand children objects 

the amount of information returned on the deepest level should IMO be independent of the depth
value. 

{{count}} as currently documented is only applied to the root of the returned subtree. this
would imply that the implementation has to always return *all* child nodes on deeper levels,
even for potentially very large child node sets.

i suggest we rename {{count}} to {{maxChildNodes}} and apply it on every level of the returned
subtree.    

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message