jackrabbit-oak-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (Commented) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (OAK-65) Naming of NodeState and related classes
Date Fri, 13 Apr 2012 16:35:17 GMT

    [ https://issues.apache.org/jira/browse/OAK-65?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13253520#comment-13253520

Michael Dürig commented on OAK-65:

I tend to disagree for my reasons given above. I can live with the current names though. However
we still need to come up with a better name for TransientNodeState. That name as earned a
lot of critique (and rightly so) but no one came up with a better name so far either. 
> Naming of NodeState and related classes
> ---------------------------------------
>                 Key: OAK-65
>                 URL: https://issues.apache.org/jira/browse/OAK-65
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: core, mk
>            Reporter: Michael Dürig
> As discussed here [1] we should rethink the nameing of the NodeState and related classes.

> I suggest the following renaming:
> NodeState -> NodeData
> PropertyState -> PropertyData
> TransientNodeState -> NodeState
> KernelNodeState -> KernelNodeData
> My reasoning: the current NodeState and PropertyState classes are immutable (and thus
> represent pure values i.e. data). The word state implies mutability
> (after all OOP is about mutation of state all over) so renaming
> TransientNodeState to NodeState should make sense. Also the oak API will
> be more publicly visible than the lower level MK API. So having catchy
> names there is a plus. 
> http://markmail.org/thread/xi5dgjljduc7y7eq

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message