jackrabbit-oak-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-10) Impedance mismatch between signatures of NodeState#getChildeNodeEntries and MicroKernel#getNodes
Date Mon, 12 Mar 2012 16:57:38 GMT

    [ https://issues.apache.org/jira/browse/OAK-10?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13227683#comment-13227683
] 

Jukka Zitting commented on OAK-10:
----------------------------------

I set the parameter type to long for consistency with the offset parameter, but as you said,
it could just as well be an int. I'm fine also with renaming the parameter.
                
> Impedance mismatch between signatures of NodeState#getChildeNodeEntries and MicroKernel#getNodes
> ------------------------------------------------------------------------------------------------
>
>                 Key: OAK-10
>                 URL: https://issues.apache.org/jira/browse/OAK-10
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>            Reporter: Michael Dürig
>             Fix For: 0.1
>
>
> NodeState#getChildeNodeEntries uses long for its lenght parameter while MicroKernel#getNodes
uses int. In order to implement the NodeState interface on top of the Microkernel, it would
be favourable if the type would be the same. 
> I suggest we change it to int for both methods since a length bigger than Integer.MAX_VALUE
is not realistic anyway. On a related note, I'd rename the parameter from length to count.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message