jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Reschke <julian.resc...@gmx.de>
Subject Re: FileVault: Require Java 8
Date Thu, 05 Sep 2019 07:43:10 GMT
On 05.09.2019 03:18, Tobias Bocanegra wrote:
> Hi,
>
> ok. So from the jackrabbit / oak side we have:
>
> - Jackrabbit 2.18 - recommended version for Java 8 and newer
> - Jackrabbit 2.16 - Java 8 and newer
> - Jackrabbit 2.14 - recommended version for Java 7 - “end of life” planned for Spring
2022
>
> - Apache Jackrabbit Oak 1.16.0 (Java 8 and later)
> - Apache Jackrabbit Oak 1.10.x (Java 8 and later)
> - Apache Jackrabbit Oak 1.8.x (Java 8 and later)
> - Apache Jackrabbit Oak 1.6.x (Java 7 and later)
>
> The relevant part for the vault-core osgi bundle is the dependency on the jackrabbit
APIs. It has no direct bundle dependency to
> Oak. Also, it doesn't embed any other bundles, so as long as the APIs stay Java version
independent, it should all work.
> ...

Even if the JAR file for jackrabbit-api is compiled with Java 8?

Best regards, Julian

Mime
View raw message