jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thierry Ygé (JIRA) <j...@apache.org>
Subject [jira] [Commented] (JCRVLT-113) Skip installation of sub packages if newer version is already present and installed
Date Tue, 05 Apr 2016 13:00:27 GMT

    [ https://issues.apache.org/jira/browse/JCRVLT-113?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15226203#comment-15226203
] 

Thierry Ygé commented on JCRVLT-113:
------------------------------------

added sample patch in the pull request -> https://github.com/apache/jackrabbit-filevault/pull/4

> Skip installation of sub packages if newer version is already present and installed
> -----------------------------------------------------------------------------------
>
>                 Key: JCRVLT-113
>                 URL: https://issues.apache.org/jira/browse/JCRVLT-113
>             Project: Jackrabbit FileVault
>          Issue Type: Improvement
>          Components: Packaging
>    Affects Versions: 3.1.26
>            Reporter: Thierry Ygé
>             Fix For: 3.1.28
>
>
> In our testing environment we release package that may contains dependency library (for
ui testing), when different ui testing modules are installed separately  it may happen then
that the embedded sub package contains an older version than the one currently installed,
and that produce issues.
> To avoid that, it would help if during the package installation, the extract process
would check for sub packages if another package of same group/name is already installed and
is more recent, and so skip it.
> I have prepared a sample solution, including the junit test to validate it.
> It would be great to add this in the next release.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message