jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig <mdue...@apache.org>
Subject Re: Why does JackRabbit use Lucene 3.6 and not 4.7?
Date Fri, 15 Aug 2014 10:33:14 GMT

Jackrabbit's integration with Lucene is quite deep, which makes 
upgrading to newer Lucene versions difficult. So far there wasn't enough 
cases for upgrading and no one was willing to bit the bullet and work on 
an upgrade.

Michael

On 11.8.14 9:54 , wkoorn@xebia.com wrote:
>
> I'm trying to combine two libraries in my single jar web app: ElasticSearch
> and JackRabbit.
>
> The former depends on Lucene 4.7 which is quite up-to-date where the latter
> depends on Lucene 3.6 which is quite older.
>
> Is there any specific reason why the latest JackRabbit (2.8) is still on
> Lucene 3.6?
>
>
>
> Regards, Wilco.
>
>
>
> --
> View this message in context: http://jackrabbit.510166.n4.nabble.com/Why-does-JackRabbit-use-Lucene-3-6-and-not-4-7-tp4661212.html
> Sent from the Jackrabbit - Dev mailing list archive at Nabble.com.
>

Mime
View raw message