jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Munteanu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCRVLT-52) Set maven-compiler-plugin target/source version to 1.6
Date Thu, 03 Jul 2014 08:49:24 GMT

     [ https://issues.apache.org/jira/browse/JCRVLT-52?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Munteanu updated JCRVLT-52:
----------------------------------

    Attachment: JCRVLT-52-1.diff

> Set maven-compiler-plugin target/source version to 1.6
> ------------------------------------------------------
>
>                 Key: JCRVLT-52
>                 URL: https://issues.apache.org/jira/browse/JCRVLT-52
>             Project: Jackrabbit FileVault
>          Issue Type: Task
>    Affects Versions: 3.1.2
>            Reporter: Robert Munteanu
>         Attachments: JCRVLT-52-1.diff
>
>
> The parent pom sets the maven-compiler-plugin version source/target version to 1.5. However,
Java 6 specific methods are already used, such as 
> * String#isEmpty
> * IOException(String, Exception)
> * TreeMap.firstEntry
> The source/target versions should be set to 1.6 .



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message