jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Parvulescu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCR-3481) NullPointerException in DescendantSelfAxisScorer#nextDoc
Date Mon, 17 Dec 2012 15:39:11 GMT

    [ https://issues.apache.org/jira/browse/JCR-3481?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13534000#comment-13534000
] 

Alex Parvulescu commented on JCR-3481:
--------------------------------------

Hi,
I do believe this is a duplicate of JCR-3407, and the NPE protection has been backported to
the 2.4 branch with JCR-3428. You can also see it on the svn branch directly[0]

Have you guys tried updating to a newer 2.4.x release?


[0] http://svn.apache.org/viewvc/jackrabbit/branches/2.4/jackrabbit-core/src/main/java/org/apache/jackrabbit/core/query/lucene/DescendantSelfAxisQuery.java?view=markup#l477

                
> NullPointerException in DescendantSelfAxisScorer#nextDoc
> --------------------------------------------------------
>
>                 Key: JCR-3481
>                 URL: https://issues.apache.org/jira/browse/JCR-3481
>             Project: Jackrabbit Content Repository
>          Issue Type: Bug
>          Components: jackrabbit-core
>    Affects Versions: 2.4.2
>         Environment: Magnolia CMS 4.4.9-jr24, Jackrabbit 2.4.2, Lucene 3.0.3, XPath
>            Reporter: Edgar Vonk
>         Attachments: error-log.txt
>
>
> For certain XPath search queries we get nullpointerexceptions in the DescendantSelfAxisScorer#nextDoc
method because the 'subScorer' var is null.
> It seems other people have the issue as well:
> http://jackrabbit.510166.n4.nabble.com/JCR-SQL2-query-NullPointerException-in-DescendantSelfAxisQuery-td4657009.html
> It seems a bit arbitrary when it occurs. It seems to occur only when we search using
certain short search terms. Also it occurs on stem words when we configure to use a different
Lucene analyzer in Jackrabbit (e.g. the DutchAnalyzer and searching on 'een' or 'het').
> We use a custom Jackrabbit indexing-configuration.xml but I even tried without using
a indexing-configuration and also then the problem occurs. 
> Any ideas on what could cause this?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message