jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ard Schrijvers <a.schrijv...@onehippo.com>
Subject Re: Is it ok tika version for jackrabbit 2.2.x branch from 0.8 to at least 0.9?
Date Fri, 30 Nov 2012 14:14:45 GMT
On Fri, Nov 30, 2012 at 3:10 PM, Jukka Zitting <jukka.zitting@gmail.com> wrote:
> Hi,
>
> On Fri, Nov 30, 2012 at 3:57 PM, Ard Schrijvers
> <a.schrijvers@onehippo.com> wrote:
>> Are there objections against bumping Tika from 0.8 to at least 0.9 for
>> the 2.2.x branch?
>
> Upgrading dependencies in a maintenance branch is a bit troublesome as
> the risk of introducing unexpected problems is higher than with
> simpler code changes. Thus the benefits should be carefully weighed
> against the potential risk.
>
> One way to reduce the potential impact is to only update the Tika
> dependency in the war, rar, and standalone jar archives, but leave the
> dependency in jackrabbit-core unchanged so we don't accidentally mess
> up with transitive dependencies of downstream projects. A downstream
> project that embeds Jackrabbit but still wants the Tika update can
> still do so locally by explicitly upgrading the version of the Tika
> dependency.

Fair enough. I assumed tika 0.9 to be compatible with 0.8, but I am ok
with your reasoning. I am already upgrading the tika dependency in our
downstream projects. I'll keep it that way for the 2.2.x branch.

Thanks for your feedback Jukka,

Regards Ard

>
> BR,
>
> Jukka Zitting



-- 
Amsterdam - Oosteinde 11, 1017 WT Amsterdam
Boston - 1 Broadway, Cambridge, MA 02142

US +1 877 414 4776 (toll free)
Europe +31(0)20 522 4466
www.onehippo.com

Mime
View raw message