jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Mueller (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCR-3396) Simplify the code when possible
Date Tue, 24 Jul 2012 07:48:36 GMT

    [ https://issues.apache.org/jira/browse/JCR-3396?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13421248#comment-13421248
] 

Thomas Mueller commented on JCR-3396:
-------------------------------------

Hi Julian

I agree, whatever is more readable is OK.

(I actually didn't want to create a bug for JCR but for OAK, so I will close this issue).
                
> Simplify the code when possible
> -------------------------------
>
>                 Key: JCR-3396
>                 URL: https://issues.apache.org/jira/browse/JCR-3396
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Priority: Minor
>
> Sometimes it's possible to simplify the code, for example:
> - making methods static when possible, so a reader knows the method doesn't change the
state of an object
> - the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message