jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@adobe.com>
Subject Re: time for JDK 1.6?
Date Thu, 31 May 2012 08:28:52 GMT
Hi,

Am 31.05.2012 um 10:22 schrieb Julian Reschke:

> Hi,
> 
> yesterday, while working on OAK, I accidentally made a jackrabbit 
> (-tests) change containing a 1.6ism (String.isEmpty). Nothing serious, 
> and easy to fix.

Technically I am all for dropping the Java 5 requirement -- Java 5 is essentially no more.

On the other hand: In Sling we have setup the Codehaus Animal Sniffer plugin to verify Java
5 API use only and fail the build otherwise.

Regards
Felix


> 
> But it makes me wonder whether it makes sense to use 1.6 in OAK, but 1.5 
> in Jackrabbit (given the fact that we use subprojects from jackrabbit, 
> such as -tests and -commons).
> 
> Best regards, Julian


Mime
View raw message