jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Meschberger (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (JCR-3293) AbstractLoginModule: get rid of trust_credentials_attribute
Date Tue, 17 Apr 2012 08:15:18 GMT

     [ https://issues.apache.org/jira/browse/JCR-3293?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Felix Meschberger updated JCR-3293:
-----------------------------------

    Description: 
based on JCR-2355 we added a very simplistic way to indicate to the login module that the
given credentials have
been preauthenticated. as already stated in the original issue this poses a major security
issue as it leaves the
repository access untrusted.

i would like to raise those security concern again and would therefore like to get rid of
that hack in the long run.
the suggested procedure:

- deprecate the attribute (immediately)
- log a warning if it is used (immediately)
- document how to fix code that is currently relying on that attribute
- remove support altogether for the next major release

  was:
based on JCR 2355 we added a very simplistic way to indicate to the login module that the
given credentials have
been preauthenticated. as already stated in the original issue this poses a major security
issue as it leaves the
repository access untrusted.

i would like to raise those security concern again and would therefore like to get rid of
that hack in the long run.
the suggested procedure:

- deprecate the attribute (immediately)
- log a warning if it is used (immediately)
- document how to fix code that is currently relying on that attribute
- remove support altogether for the next major release

    
> AbstractLoginModule: get rid of trust_credentials_attribute
> -----------------------------------------------------------
>
>                 Key: JCR-3293
>                 URL: https://issues.apache.org/jira/browse/JCR-3293
>             Project: Jackrabbit Content Repository
>          Issue Type: Bug
>          Components: jackrabbit-core
>    Affects Versions: 2.4
>            Reporter: angela
>
> based on JCR-2355 we added a very simplistic way to indicate to the login module that
the given credentials have
> been preauthenticated. as already stated in the original issue this poses a major security
issue as it leaves the
> repository access untrusted.
> i would like to raise those security concern again and would therefore like to get rid
of that hack in the long run.
> the suggested procedure:
> - deprecate the attribute (immediately)
> - log a warning if it is used (immediately)
> - document how to fix code that is currently relying on that attribute
> - remove support altogether for the next major release

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message