jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Parvulescu (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCR-3241) Jackrabbit does not deploy on JBoss AS 7.1.0 Final
Date Mon, 12 Mar 2012 16:57:38 GMT

    [ https://issues.apache.org/jira/browse/JCR-3241?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13227682#comment-13227682
] 

Alex Parvulescu commented on JCR-3241:
--------------------------------------

If I understand correctly ironjacamar uses the 1.6 spec to validate the archives which is
more strict that the 1.5 version.
So apparently the temporary workaround is to disable archive validation within the JCA subsystem.

I'll lower the priority as the workaround seems pretty common for other projects who ran into
the same issue.

Can you test Marek's solution and just add hashCode & equals and see if that is enough
to get you going?
                
> Jackrabbit does not deploy on JBoss AS 7.1.0 Final
> --------------------------------------------------
>
>                 Key: JCR-3241
>                 URL: https://issues.apache.org/jira/browse/JCR-3241
>             Project: Jackrabbit Content Repository
>          Issue Type: Bug
>          Components: jackrabbit-jca
>    Affects Versions: 2.2.10
>            Reporter: Claudiu Muresan
>            Priority: Blocker
>
> When deploying Jackrabbit JCA rar (resource adapter archive) on JBoss 7.1.0 final we
have the following errors:
>   Section: 19.4.2
>   Description: A ResourceAdapter must implement a "public int hashCode()" method.
>   Code: org.apache.jackrabbit.jca.JCAResourceAdapter
>   Severity: ERROR
>   Section: 19.4.2
>   Description: A ResourceAdapter must implement a "public boolean equals(Object)" method.
>   Code: org.apache.jackrabbit.jca.JCAResourceAdapter
> JBoss ironjacamar runs a validation sequence on the JCAResourceAdapter which seems to
not conform to EE6 specifications.
> I tried with latest jackrabbit version and I have the same result.
> I need to use jackrabbit with JBoss 7.1.0 so this issue is kind of blocking. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message