jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Stocker <christian.stoc...@liip.ch>
Subject JSOP/davex and transactions not working (compared to "simple webdav")
Date Mon, 05 Mar 2012 06:36:54 GMT
Hi

One thing I still get not working with using JSOP. Transactions.

It works, when I eg. create a new Node with LOCK/MKCOL/UNLOCK, put it
doesn't with the diff format in a POST:

In details how it worked before (the important parts)

***
LOCK /server/default/jcr:root HTTP/1.1

<D:lockinfo xmlns:D="DAV:" xmlns:jcr="http://www.day.com/jcr/webdav/1.0">
	<D:lockscope>
		<jcr:local />
	</D:lockscope>
	<D:locktype>
		<jcr:transaction />
	</D:locktype>
</D:lockinfo>
**
MKCOL /server/default/jcr:root/foo HTTP/1.1
TransactionId: <opaquelocktoken:6b78a37a-1513-4673-bd43-6a254538bd40>

<sv:node xmlns:sv="http://www.jcp.org/jcr/sv/1.0"
xmlns:nt="http://www.jcp.org/jcr/nt/1.0" sv:name="foo">
	<sv:property sv:name="jcr:primaryType" sv:type="Name">
		<sv:value>nt:unstructured</sv:value>
	</sv:property>
</sv:node>
**
UNLOCK /server/default/jcr:root HTTP/1.1
Lock-Token: <opaquelocktoken:1a252718-18bf-40a3-ab7f-b5559c887143>

<jcr:transactioninfo xmlns:jcr="http://www.day.com/jcr/webdav/1.0">
	<jcr:transactionstatus>
		<jcr:rollback />
	</jcr:transactionstatus>
</jcr:transactioninfo>
***

With the <jcr:rollback/> at the end, that node never gets finally created.

But if I do exactly the same, just with a POST and :diff instead of the
MKCOL (and the LOCK/UNLOCK before/after)

***
POST /server/default/jcr:root/ HTTP/1.1
TransactionId: <opaquelocktoken:69125aba-3117-4a45-baf2-44e958364dc3>

:diff=+/foo : {"jcr:primaryType":"nt:unstructured",}
***

That node gets created even with a rollback afterwards.

Is this a bug? Or a missing feature? Or do transactions work differently
here? I tried to find the problem by myself in jackrabbit-jcr-server,
but was not really successful, therefor any help would be appreciated.

greetings

chregu


-- 
Liip AG  //  Feldstrasse 133 //  CH-8004 Zurich
Tel +41 43 500 39 81 // Mobile +41 76 561 88 60
www.liip.ch // blog.liip.ch // GnuPG 0x0748D5FE


Mime
View raw message