jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Pfister <dpfis...@adobe.com>
Subject Re: [jr3] Tree model
Date Mon, 05 Mar 2012 09:31:40 GMT

On Mar 5, 2012, at 10:20 AM, Thomas Mueller wrote:

>> Note that if we do mandate orderability on child nodes, supporting
> So in your model a "tree" is a node? A "leaf" is a property? What is a
> branch, a "child node"?
> I prefer using the same terms for the same things consistently. A node
> shouldn't sometimes be called node and sometimes tree. I understand we
> have a naming conflict here with javax.jcr.Node and Property, but what
> about name combinations:
> - NodeData
> - PropertyData
> - ChildList

I usually associate the suffix "Data" with classes that are rather  
dumb and contain nothing but setters and getters. IMO, the Tree/Leaf/ 
Branch naming convention looks much more consistent and intutive, now  
that the Tree.isLeaf() method is gone, which sounded illogical...


View raw message