jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakub Liska <liska.ja...@gmail.com>
Subject Re: Lucene 3.x to run with JR 2.2.8 ?
Date Sun, 28 Aug 2011 09:57:25 GMT
This is not much of an option, the application is Liferay portal and
presence of jackrabbit in common classloader is not an option from many
reasons. Jackrabbit 2.x actually work with Lucene 3.0.3 except for some
exceptions like HitCollector absence etc.

On Sun, Aug 28, 2011 at 11:46 AM, Jukka Zitting <jukka.zitting@gmail.com>wrote:

> Hi,
>
> On Sun, Aug 28, 2011 at 11:20 AM, Jakub Liska <liska.jakub@gmail.com>
> wrote:
> > does anybody know when 2.3.0 version of Jackrabbit is out ?
>
> We haven't yet set a release date, but I'd expect something around the
> end of the year.
>
> > The problem is that a lot of application is using Lucene 3.x or 3.1.x and
> > Jackrabbit is quite incompatible with this version ... It still uses 2.4
> > version of lucene which is a huge step down from lucene 3.3.
>
> Have you considered using a "model 2" deployment [1] where Jackrabbit
> is run under a different classloader than your application? That way
> you can use the latest Lucene version in your application while
> Jackrabbit still uses 2.4.x.
>
> [1] http://jackrabbit.apache.org/deployment-models.html
>
> BR,
>
> Jukka Zitting
>

Mime
View raw message