jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Parvulescu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (JCR-2954) SQL-2 query returns more than the requested column
Date Tue, 24 May 2011 11:57:47 GMT

    [ https://issues.apache.org/jira/browse/JCR-2954?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13038514#comment-13038514
] 

Alex Parvulescu commented on JCR-2954:
--------------------------------------

hi Benjamin,

interesting find!

I've looked over this issue a little bit and the problem is better solved deeper, in the Parser
class in jcr-commons. I've included a few tests, take a quick look and let me know what you
think.

> SQL-2 query returns more than the requested column
> --------------------------------------------------
>
>                 Key: JCR-2954
>                 URL: https://issues.apache.org/jira/browse/JCR-2954
>             Project: Jackrabbit Content Repository
>          Issue Type: Bug
>          Components: query
>    Affects Versions: 2.2.5
>            Reporter: Benjamin Papez
>            Priority: Minor
>         Attachments: QueryEngine.patch
>
>
> If I do :
> SELECT alias.[jcr:title] FROM [jnt:mainContent] as alias
> and then iterate through the returned columns of the rows, I get the same result as for
:
> SELECT * FROM [jnt:mainContent] 
> which is ALL the properties defined for jnt:mainContent.
> Only if I use
> SELECT alias.[jcr:title] as title FROM [jnt:mainContent] as alias
> the result is limited to the title column.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message