Hi all,

I'm trying to use the jackRabbit WebDav client. So I downloaded the source and deployed the jackRabbit artifact on my maven repository. But when I'm trying to embed the jackRabbit WebDav client, I got a SLF4J versionning conflict. Checking dependencies, I found:

[INFO] +- org.apache.jackrabbit:jackrabbit-webdav:jar:2.3-SNAPSHOT:compile
[INFO] |  +- org.slf4j:slf4j-api:jar:1.5.6:compile
[INFO] |  +- commons-httpclient:commons-httpclient:jar:3.0:compile
[INFO] |  |  \- commons-codec:commons-codec:jar:1.2:compile
[INFO] |  \- org.slf4j:jcl-over-slf4j:jar:1.6.1:compile

So obviously, the commons-httpclient is using version 1.6.1 of the API which is not compatible with the 1.5.6... Is it a known problem on the trunk ? 

--
Gérard Dupont
Information Processing Control and Cognition (IPCC)
CASSIDIAN - an EADS company

Document & Learning team - LITIS Laboratory