jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gustavo Orair (JIRA)" <j...@apache.org>
Subject [jira] Created: (JCR-2893) Conflicts between commons-collections-3.2 from JBOSS AS 6 and commons-collections-3.1 from Jackrabbit-JCA
Date Wed, 16 Feb 2011 00:00:57 GMT
Conflicts between commons-collections-3.2 from JBOSS AS 6 and commons-collections-3.1 from
Jackrabbit-JCA
---------------------------------------------------------------------------------------------------------

                 Key: JCR-2893
                 URL: https://issues.apache.org/jira/browse/JCR-2893
             Project: Jackrabbit Content Repository
          Issue Type: Bug
          Components: config, jackrabbit-jca
    Affects Versions: 2.2.2, 2.2.4
         Environment: Linux Ubuntu, JBOSS AS 6 Final
            Reporter: Gustavo Orair
            Priority: Minor


When I try to deploy Jackrabbit-JCA on JBOSS AS 6 it fails with a strange error:
18:30:10,029 WARN  [ClassLoaderManager] Unexpected error during load of:org.apache.commons.collections.DoubleOrderedMap$2$1:
java.lang.IllegalAccessError: class org.apache.commons.collections.DoubleOrderedMap$2$1 cannot
access its superclass org.apache.commons.collections.DoubleOrderedMap$DoubleOrderedMapIterator


This problem is probably related do class loading on JBOSS AS 6. JBOSS AS 6 has a commons-collections
version 3.2 on app libs.
So, it is prefered instead of  commons-collections version 3.1 existing inside the jackrabbit-jca.rar.


The solution is related to include in the rar the file 
jboss-classloading.xml instructing JBoss to not load commons-collections 3.2 for the adapter.
Another solution would be update commons-collections to version 3.2

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message