jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From edamico <estebandam...@gmail.com>
Subject Cluster Problems
Date Mon, 17 Jan 2011 16:14:19 GMT

Hi all,
  We are developing a CMS application using Apache JackRabbit 2.2.1, and we
are experimenting some problems while trying to cluster the application. 

The problem could be described as follows:
First we write in ServerA, and this server persists the latest modifications
into it's workspace, and persist the changes into GlobalServer journal
database.
After that, when ServerB, syncs the changes (every 5000ms), it notices about
the new modifications and retrieves the journal from the GlobalServer
journal database. That data is deserialized and both, the cache and the
search index are modified with the modifications and deletions, but ServerB
workspace(local workspace bundle table is not refreshed) repository is not
being refresh with the latest changes publish in ServerA.
We have read all posts and debug the code, but we are unable to solve this
issue.
We attach the repository.xml configuration file of serverA node.
ServerB configuration is the same, with the same workspace, but connections
IPs are different.

http://jackrabbit.510166.n4.nabble.com/file/n3221229/repository.xml
repository.xml 

Please, it would be great if you could help us.
Regards,
Esteban D'Amico

-- 
View this message in context: http://jackrabbit.510166.n4.nabble.com/Cluster-Problems-tp3221229p3221229.html
Sent from the Jackrabbit - Dev mailing list archive at Nabble.com.

Mime
View raw message