jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jukka Zitting <jzitt...@adobe.com>
Subject Re: unable to build trunk: missing dependency
Date Thu, 09 Dec 2010 13:33:43 GMT
Hi,

On 09/12/10 14:08, Michael Dürig wrote:
> On 9.12.10 13:49, Stefan Guggisberg wrote:
>> i am unable to build jackrabbit trunk (r1043943).
>> maven is complaining about some missing dependency,
>>
>> edu.ucar:netcdf:jar:4.2-min
>>
>> am i the only one having problems?
>> what is this dependency for?
>
> That dependency seems to come from Tika.

Yes, Tika recently added support for some scientific data formats (see 
TIKA-400 [1]) using the NetCDF library.

Support for those formats is probably not a high priority for most 
content repositories, but it doesn't cost much to have that feature 
included by default in Jackrabbit.

When upgrading to Tika 0.8 in in JCR-2817 [2] I had to explicitly 
exclude the NetCDF library because of classpath problems raised in 
TIKA-556 [3]. However, when testing 2.2.0 yesterday I found that we 
should either explicitly disable the relevant Tika parser due to the 
missing dependency or bring back the NetCDF 4.2-min dependency that was 
meanwhile fixed in TIKA-556. The latter seemed like a better option so I 
did that in JCR-2838 [4].

[1] https://issues.apache.org/jira/browse/TIKA-400
[2] https://issues.apache.org/jira/browse/JCR-2817
[3] https://issues.apache.org/jira/browse/TIKA-556
[4] https://issues.apache.org/jira/browse/JCR-2838

BR,

Jukka Zitting

Mime
View raw message