jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Updated: (JCR-2089) Use java.util.concurrent
Date Wed, 07 Apr 2010 11:27:33 GMT

     [ https://issues.apache.org/jira/browse/JCR-2089?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jukka Zitting updated JCR-2089:
-------------------------------

    Fix Version/s:     (was: 2.1.0)

There are some rather tricky uses of concurrent.jar locks in jackrabbit-core that'll need
quite a bit of attention when migrating as there are no exactly equivalent classes in java.util.concurrent.
Dropping the 2.1.0 target.

> Use java.util.concurrent
> ------------------------
>
>                 Key: JCR-2089
>                 URL: https://issues.apache.org/jira/browse/JCR-2089
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>          Components: jackrabbit-core
>            Reporter: Jukka Zitting
>
> Now after JCR-2087 we can use Java 5 class libraries in Jackrabbit. One major new thing
in Java 5 is the java.util.concurrent library that we can use to replace the concurrent.jar
dependency we have now.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message