jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Mueller (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (JCR-2450) UserManager inconsistency
Date Thu, 18 Mar 2010 10:38:27 GMT

     [ https://issues.apache.org/jira/browse/JCR-2450?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Thomas Mueller resolved JCR-2450.
---------------------------------

    Resolution: Not A Problem

Closing as "not a problem". Please re-open if the problem persists.

> UserManager inconsistency
> -------------------------
>
>                 Key: JCR-2450
>                 URL: https://issues.apache.org/jira/browse/JCR-2450
>             Project: Jackrabbit Content Repository
>          Issue Type: Bug
>          Components: jackrabbit-core, security
>    Affects Versions: 1.6.0, 2.0-beta4
>         Environment: Ubuntu 9.04 64bit, Tomcat 6.0.20, Jackrabbit 1.6 and 2.0-beta4
>            Reporter: Michael Stämpfli
>            Priority: Blocker
>         Attachments: jackrabbit-test.zip
>
>
> I used the default class UserManagerImpl to add a user to my jackrabbit (1.6) environment.
My application can successfully login to the repository with this user. As soon as I restart
Tomcat, the login fails.
> I did some research and found out why. Obviously the user manager cannot find the user,
I registered previously, anymore. Using WebDAV I made a connection to the security workspace.
When I create a new user, a new node for this user is created in /jcr:root/rep:security/rep:authorizables/rep:users/admin.
As soon as I restart Tomcat and login to the security workspace again (using WebDAV), I see
that the user node moved to the root node. As a consequence the user cannot login to the repository
because the user manager cannot find the user node anymore.
> In jackrabbit 2.0-beta4 I get a similar bug and I assume, that the root cause is the
same as above. I log into the repository using the administrator account, which is created
automatically with the class UserManagerImpl. When I restart Tomcat and try to login to the
repository I get the error: javax.jcr.ItemNotFoundException: failed to build path of 55411ff4-d6c7-410a-a16e-5531e1c7afae:
cafebabe-cafe-babe-cafe-babecafebabe has no child entry for 55411ff4-d6c7-410a-a16e-5531e1c7afae

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message