jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Stämpfli (JIRA) <j...@apache.org>
Subject [jira] Commented: (JCR-2450) UserManager inconsistency
Date Thu, 18 Mar 2010 09:04:27 GMT

    [ https://issues.apache.org/jira/browse/JCR-2450?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12846797#action_12846797
] 

Michael Stämpfli commented on JCR-2450:
---------------------------------------

I deployed the standard jackrabbit webapp to my tomcat and created a new repository. So my
repository should have the same simple configuration as yours. Then I played the login game
with several different configurations.

When I use the derby persistence manager everything works perfectly. I even changed the security
manager to DefaultSecurityManager, the access manager to DefaultAccessManager and the login
module to DefaultLoginModule (those are the ones I use in my application). It still worked.
This proves what you said before. If you don't change the persistence manager, there is no
problem.

As said before the file persistence manager works too.

Then I changed the persistence manager to MySQL. The following list shows, which configuration
worked and which showed the error described above:
* SimpleSecurityManager, SimpleAccessManager, SimpleLoginModule with security workspace "security"
-> works
* DefaultSecurityManager, DefaultAccessManager, DefaultLoginModule with security workspace
"security" -> ERROR
* DefaultSecurityManager, DefaultAccessManager, DefaultLoginModule with security workspace
"default" -> works

I hope this will help you.

> UserManager inconsistency
> -------------------------
>
>                 Key: JCR-2450
>                 URL: https://issues.apache.org/jira/browse/JCR-2450
>             Project: Jackrabbit Content Repository
>          Issue Type: Bug
>          Components: jackrabbit-core, security
>    Affects Versions: 1.6.0, 2.0-beta4
>         Environment: Ubuntu 9.04 64bit, Tomcat 6.0.20, Jackrabbit 1.6 and 2.0-beta4
>            Reporter: Michael Stämpfli
>            Priority: Blocker
>         Attachments: jackrabbit-test.zip
>
>
> I used the default class UserManagerImpl to add a user to my jackrabbit (1.6) environment.
My application can successfully login to the repository with this user. As soon as I restart
Tomcat, the login fails.
> I did some research and found out why. Obviously the user manager cannot find the user,
I registered previously, anymore. Using WebDAV I made a connection to the security workspace.
When I create a new user, a new node for this user is created in /jcr:root/rep:security/rep:authorizables/rep:users/admin.
As soon as I restart Tomcat and login to the security workspace again (using WebDAV), I see
that the user node moved to the root node. As a consequence the user cannot login to the repository
because the user manager cannot find the user node anymore.
> In jackrabbit 2.0-beta4 I get a similar bug and I assume, that the root cause is the
same as above. I log into the repository using the administrator account, which is created
automatically with the class UserManagerImpl. When I restart Tomcat and try to login to the
repository I get the error: javax.jcr.ItemNotFoundException: failed to build path of 55411ff4-d6c7-410a-a16e-5531e1c7afae:
cafebabe-cafe-babe-cafe-babecafebabe has no child entry for 55411ff4-d6c7-410a-a16e-5531e1c7afae

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message