jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tobias Bocanegra (JIRA)" <j...@apache.org>
Subject [jira] Created: (JCR-2399) Enable protected security importers by default
Date Fri, 20 Nov 2009 13:11:39 GMT
Enable protected security importers by default
----------------------------------------------

                 Key: JCR-2399
                 URL: https://issues.apache.org/jira/browse/JCR-2399
             Project: Jackrabbit Content Repository
          Issue Type: Wish
          Components: jackrabbit-core
    Affects Versions: 2.0-beta1
            Reporter: Tobias Bocanegra


We added those cool protected property and node importers for enabling sysview import of users,groupd
and acls. unfortunately, they are only
enabled when the respective config is set:

<Import>
  <ProtectedNodeImporter class="org.apache.jackrabbit.core.xml.AccessControlImporter"/>
  <ProtectedPropertyImporter class="org.apache.jackrabbit.core.security.user.UserImporter">
    <param name="importBehavior" value="besteffort"/>
  </ProtectedPropertyImporter>
</Import>

i think we should enable them by default, i.e. for an empty config. if someone wants to disable
them, they can still reference the default importers:

<Import>
  <ProtectedNodeImporter class="org.apache.jackrabbit.core.xml.DefaultProtectedNodeImporter"/>
  <ProtectedPropertyImporter class="org.apache.jackrabbit.core.xml.DefaultProtectedPropertyImporter"
/>
</Import>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message