jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From EricCart <ericc...@gmail.com>
Subject Re: [jira] Created: (JCR-2344) ClassCastException org.apache.xerces.parsers.XIncludeAwareParserConfiguration cannot be cast to org.apache.xerces.xni.parser.XMLParserConfiguration when deploying in JBoss 5.1
Date Wed, 14 Oct 2009 16:32:46 GMT


The workaround: remove xercesImpl-2.8.1.jar and xml-apis-1.3.03.jar from
Jackrabbit jca and war, leaving the daful Jboss libs.

E


EricCart wrote:
> 
> I have hit the same issue. I think it's a library collision around
> xercesImpl-2.8.jar1 and endorsed/xercesImpl.jar
> 
> How can it be fixed ?
> 
> Thanks,
> Eric
> 

-- 
View this message in context: http://www.nabble.com/-jira--Created%3A-%28JCR-2344%29-ClassCastException-org.apache.xerces.parsers.XIncludeAwareParserConfiguration-cannot-be-cast-to-org.apache.xerces.xni.parser.XMLParserConfiguration-when-deploying-in-JBoss-5.1-tp25721050p25894472.html
Sent from the Jackrabbit - Dev mailing list archive at Nabble.com.


Mime
View raw message